v2.4.4.2: Juli 2019

Um Inkonsistenzen zu beseitigen, die durch das Speichern gleicher oder ähnlicher Informationen in unterschiedlichen Dateien auftraten (historisch bedingt), wurden Anpassungen von Dateistrukturen und Datei-Inhalten durchgeführt, die bei einem Zugriff auf alte bereits erstellte Mz3 Projekte zu unerwarteten Ergebissen führen können.
So können z.B. die Seitenzahl und Seitengröße, aber auch die Anzahl der Sprachen falsch sein (auf die Defaultwerte zurückgesetzt).
Auch wird die PDF-Datei, aus der ein Mz3 Titel erstellt wurde, nicht mehr gefunden, kann aber mit “Use Other PDF” wieder ausgewählt werden und wird dann auch wieder gespeichert.

Viele dieser Inkompatibilitäten können durch das Ausführen von “Commands – Update” behoben werden. Alle Konfigurationsdateien werden dann neu erstellt und gespeichert.
Soll eine weitere PDF-Konvertierung erfolgen, muss die gewünschte PDF-Datei über “File – Use Other Pdf” noch einmal zum Mz3 Projekt hinzugefügt werden.
Wir empfehlen, eine Prüfung und ggf Korrektur der Basic Settings über das Kommando: Settings – Configure Basic Settings” durchzudühren.

Sollten diese Hinweise nicht ausreichen, um ihre alten Mz3 Titel wieder korrekt zu erstellen und anzuzeigen, sprechen Sie uns bitte an!

Übersicht: Die wichtigesten Änderungen dieser Version 2.4.4.02

* Keine Flash-Unterstützung mehr
  • Die MZ3 Project Verwaltungs-Funktionen (alle im “File” Menü verfügbar), wurden komplett überarbeitet:
    • New From Pdf
    • Open Recent Project
    • Open Project
    • Save Project As
    • Delete Project
  • Die Publishing Funktionen und die Ablauflogik wurden überarbeitet
  • Die Strukturen der Config-Dateien wurden angepasst und erweitert (insbesondere die mz3ToolBookData.xml Inhalte)
  • Einfacheres Positionieren und Anpassen der Größe von AREA Elementen
  • Deutliche Verbesserung beim Verwalten mehrsprachiger Bücher über ein erweitertes und trotzdem einfacheres/komfortableres Language Selection Fenster
  • Verbessertes und komfortableres Hinzufügen von Seitenbildern (PIMGs: Page Images). Es wird jetzt versucht, automatisch die beste Strategie zu finden, um die ausgewählten Bilder auf die richtigen Seiten zu setzen.
    Trotzdem sollte man das Ergebnis vor der Übernahme überprüfen un dggf anpassen. Aber in den meisten Fällen kann man nun die Auswahl wie vorgeschlagen übernehmen!
  • Fehler-Beseitigung und einige kleiner Verbesserungen.

FLASH Unterstützung eingestellt

Da inzwischen alle Browser es dem “normalen” Nutzer fast unmöglich machen, FLASH-Programme noch zu nutzen, haben wir uns entschlossen, nach über 10 Jahren vollem FLASH-Support diesen Trend zu akzeptieren und mz3Tool entsprechend aufzuräumen.

File – Open Recent Project Feature

Dieses Kommando wurde entfernt. Die mit diesem Kommando angebotenen Funktionen können nun alle über das ‘Open Project’ Menü ausgeführt werden.

File – Open Project

Dieses Kommando ist nun das zentrale Kommando zum Verwalten und Starten/Öffnen vin Mz3 Projekten (“Mz3 Büchern”).
Es wird jetzt die Information der Original-Projektdaten genutzt (mz3ToolBookData.xml und ggf mz3-Datei aus den Projekt-Ordnern).
Die frühere mz3ToolPathsData XML Datei in dem Benutzer-spezifischen Ordner C:\Users\(userName)\AppData\Roaming\de.megazine3.air.mz3Tool\Local Store\settingsData Ordne (bei einem Windows10 System) wird nicht mehr benötigt.
Die zusätzliche Spalte “Modification Date” zeigt das Datum der letzten Änderung an. Nach dieser Spalte wird zu Beginn sortiert und man erhält die zuletzt bearbeiteten Projekte in der korrekten zeitlichen Reihenfolge. Das aktuell bearbeitete Projekt findet man in der ersten Zeile. Es ist bereits ausgewählt und wird per Doppelklick oder “OPEN” Knopf sofort wieder geöffnet.

Außerdem handelt es sich nun um ein “echtes” natives Fenster und nicht mehr um ein Pop-Up-Fenster und lässt sich daher frei positionieren und skalieren!
Es werden viele zusätzlich Informationen angezeigt, die einen guten Überblick über alle Mz3 Projekte verschaffen und Fehler/Ungereimtheiten aufdecken.
Die Tabelle zeigt nun Projekt-Details übersichtlich zusammengefasst an:

  • Änderungsdatum
  • Erstelldatum (bzw. Datum der letzten Änderung der zugrunde liegenden PDF Datei)
  • Seitenanzahl
  • Anhzahl der verfügbaren Thumbnails
  • Anzahl aller im Mz3 Projekt genutzten Elemente wie Bilder, Videos, Audio-Dateien, Links

Die Anzahl verwendeter Elemente (Bild-, Audio und Video-Dateien sowie der Thumbnails und “Seitenbilder) wird jetzt getrennt nach Sprache angezeigt.
Es kann nach allen Spalten sortiert werden. Damit sind Antworten auf die folgenden typischen Fragen schnell und komfortabel zu finden:

  • Wurden (alle) Thumbnails erzeugt?
  • Wurden alle Seiten konvertiert?
  • In welchen Büchern werden Videos genutzt?
  • Welche Sprachen werden unterstützt?
  • Welche Mz3 Titel sind mehrsprachig?
  • sind die genutzten Daten für alle Sprachen gleich
  • Welche PDF Datei wurde als Basis für die Seiten genutzt?
  • Welche Seitengrößen haben die Mz3 Titel?
  • Welches sind “Doppelseiten-Bücher”??

Sollten einige Zellen noch keine Daten enthalten (oder ein oder mehrere “?”), dann wurde das entsprechende Mz3 Projekt sehr wahrscheinlich mit einer früheren Version von mz3Tool erstellt. In diesem Fall kann eventuell ein “Commands – Update” die Konfigurationsdaten automatisch erneuern.

Neu hinzugekommen ist auch eine “Status”-Spalte mit einer Zusammenfassung des Projekt-Status:.

  • invalid
    Es wurde keine mz3oolBookData.xml Konfigurationsdatei und keine mz3 Projektdatei gefunden
  • (leer)
    Der Normalfall bei einsprachigen Büchern: Alles OK.
  • n mz3 xx
    Der Normalfall bei Vorhandensein mehrerer Sprachen: Alles OK
    “n” steht für die Anzahl gefundener mz3 Projektdateien und xx ist eine Kennung zur Auswahl-Strategie des mz3 Projekts.
    Folgende Kenungen sind möglich:
    • ML
      Die “multilingual” Datei wurde ausgewählt und es wird ein mehrsprachiges Buch angezeigt
    • SZ
      Es wurde die größte mz3-Datei gewählt (“SZ” steht für “size”)
    • LL
      Es wurde die mz3 Datei gewählt, welche der lokalen Sprache entspricht (“LL” steht für “local language”).
    • New
      Es wurde die neueste (also zuletzt bearbeitete) Projektdatei ausgewählt

Nur wenn gezielt ein einsprachiges Buch in einer der zusätzlich hinzugefügten Sprachen erstellt wird, gibt es auch die entsprechende mz3-Datei dieser Sprache und dieangezeigte ANzahl “n” der mz3 Dateien wird größer als 2.
Ein einsprachiges Buch kann auch bei mehreren vorbereiteten Sprachen leicht erstellt werden, indem die anderen Sprachen (vorübergehend) versteckt werden (“hide language”).

File – Delete Project

Die Tabelle enthält nun dieselben Inforamtionen wie die ‘Open Project’ Tabelle, was eine Kontrolle ermöglicht, bevor das Projekt gelöscht wird.
Ein gelöschtes Projekt kann nicht wieder hergestellt werden!!
Sinnvollerweise sollte vorher oder zumindest regelmäßig ein Backup aller Projektdaten erfolgen!

Commands – Publish/Distribute

Die Programmlogik zur Erstellung der Online und Offline Packages wurde überarbeitet und Fehler beseitigt. Die Benutzerführung wurde verbessert (bessere Rückmeldungen).

Mehr Komfort bei der Positionierung von AREA Elementen

Größe und Position eines AREA (klickbarer Bereich) Elements können jetzt schnell auch auf eine gesamte Seiten und Seitenhälfte (im Fall eines Doppelseitenbuchs) aufgezogen werden.
Dies hilft z.B. bei ganzseiteigen Anzeigen in einem Magazin,, die zum Hersteller verlinkt werden sollen.
Dazu steht im Haupteingabefenster ein Knopf zur Verfügung, der zwischen 4 Varianten umschaltet. Es muss nicht mehr manuell angepasst oder ins “Advanced Edit” Fenster umgeshcaltet werden:

  • ‘custom’ (manuell eingestellte) Größe und Position
    Ein manuelles Ändern der Größe oder Position eines AREA Elements schaltet wieder auf diese Variante zurück.
  • full page (komplette Seite, bei einer Doppelseite über die volle Breite eines aufgeschlagenen Buchs.
  • left half (linke Hälfte / Seite eines aufgeschlagenen Buchs)
  • right half (rechte Hälfte / Seite eines aufgeschlagenen Buchs)

Verbessertes Verwalten mehrsprachiger Bücher

Sprachen können jetzt direkt ducth Eingabe des Sprachkürzels vorbereite/definiert werden. Neue Sprachen sind nicht gleich aktiv, d.h. nicht sofort im Buch auswählbar. Sie müssen erst per Klick zur Benutzung freigegeben werden.
    

Genau so schnell können Sprachen wieder versteckt werden und kann eine (aktive) Sprache als Default-Sprache definiert werden.

Eine große Hilfe ist die vollständige Unerstützung des Löschens einer Sprache: Es werden alle Verweise und sprach-spezifischen Dateien gelöscht!
Früher musste man dies im “Manage Elements Window” mit relativ hohem Aufwand und Risiko manuell durchführen.

Verbesserte Unterstützung beim Hinzufügen von Seitenbildern

Hat man Bilder ausgewählt, die auf Seiten gesetzt werden sollen, wird der Dateiname nun recht intensiv analysiert und die beste Strategie, die Bilder auf die gewünschten Seiten zu setzen, vorgeschlagen.
Man muss in den meisten Fällen nicht mehr selber entscheiden, ob die Seitennummer aus einer Nummer im Dateinamen genutzt wird oder besser die Bilder in der (alphabetischen) Reihenfolge der Dateinamen hinzugefügt werden.
Nur in Ausnahmefällen muss man eingreifen und kann dann eine Kombination der vielfältigen Einstelloptionen nutzen, um zum gewünschten Ergebnis zu kommen.
Die Anzeige wurde aufgeräumt und übersichtlicher. Unnötige Bedienelemente sind entfallen.

Revision: 5
Last modified: 2019/07/08

Reaktion

War das hilfreich?

Ja Nein
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Hinterlasse einen Kommentar.

Kommentar senden