v2.4.4.04

Neue Major Version

Um Inkonsistenzen zu beseitigen, die durch das Speichern gleicher oder ähnlicher Informationen in unterschiedlichen Dateien auftraten (historisch bedingt), wurden Anpassungen von Dateistrukturen und Datei-Inhalten durchgeführt, die bei einem Zugriff auf alte bereits erstellte Mz3 Projekte zu unerwarteten Ergebissen führen können.
So können z.B. die Seitenzahl und Seitengröße, aber auch die Anzahl der Sprachen falsch sein (auf die Defaultwerte zurückgesetzt).
Auch wird die PDF-Datei, aus der ein Mz3 Titel erstellt wurde, nicht mehr gefunden, kann aber mit “Use Other PDF” wieder ausgewählt werden und wird dann auch wieder gespeichert.

Viele dieser Inkompatibilitäten können durch das Ausführen von “Commands – Update” behoben werden. Alle Konfigurationsdateien werden dann neu erstellt und gespeichert.
Soll eine weitere PDF-Konvertierung erfolgen, muss die gewünschte PDF-Datei über “File – Use Other Pdf” noch einmal zum Mz3 Projekt hinzugefügt werden.
Wir empfehlen, eine Prüfung und ggf Korrektur der Basic Settings über das Kommando: Settings – Configure Basic Settings” durchzudühren.

Sollten diese Hinweise nicht ausreichen, um ihre alten Mz3 Titel wieder korrekt zu erstellen und anzuzeigen, sprechen Sie uns bitte an!

Übersicht: Die wichtigesten Änderungen dieser Version 2.4.4.04

  • Keine Flash-Unterstützung mehr
  • Die MZ3 Project Verwaltungs-Funktionen (alle im “File” Menü verfügbar), wurden komplett überarbeitet:
    • New From Pdf
    • Open Recent Project
    • Open Project
    • Save Project As
    • Delete Project
  • Die Publishing Funktionen und die Ablauflogik wurden überarbeitet
  • Die Strukturen der Config-Dateien wurden angepasst und erweitert (insbesondere die mz3ToolBookData.xml Inhalte)
  • Das Fenster zur Festlegung eines “Custom Logo” wurde komplett überarbeitet. EIn Custom Logo ist jetzt im Browser “responsive”, d.h. die Größe wird an die Fensterbreite angepasst (Größe und Position jetzt als %-Wert)
  • Einfacheres Positionieren und Anpassen der Größe von AREA Elementen
  • Deutliche Verbesserung beim Verwalten mehrsprachiger Bücher über ein erweitertes und trotzdem einfacheres/komfortableres Language Selection Fenster
  • Verbessertes und komfortableres Hinzufügen von Seitenbildern (PIMGs: Page Images). Es wird jetzt versucht, automatisch die beste Strategie zu finden, um die ausgewählten Bilder auf die richtigen Seiten zu setzen.
    Trotzdem sollte man das Ergebnis vor der Übernahme überprüfen un dggf anpassen. Aber in den meisten Fällen kann man nun die Auswahl wie vorgeschlagen übernehmen!
  • Auch in der JavaScript Variante können jetzt Page Parameter (seitenspezifische Einstellungen) eingestellt werden, und in beiden Varianten werden nur die Parameter angezeigt, die auch jeweils unterstützt werden.
  • Im Video-Vorschaufenster werden jetzt auch Videos mit nicht quadratischen Pixeln korrekt angezeigt, sadass ein Preview-Bild mit dem korrekten Seitenverhältnis auch bei nicht quadratischen Pixeln aufgenommen werden kann.
  • Die Menü-Befehle “New from PDF” und “Use Other PDF” wurden vereinheitlicht und es werden mehr Warnungen und Hinweise angezeigt, z.B.:
    • Problematische Zeichen im PDF Dateinamen (wie z.B. “#”), die später im Browser oder auf dem Server Probleme bereiten könnten, werde nicht mehr zugelassen.
      In so einem Fall muss die PDF-Datei umbenannt werden.
    • Seitengröße und Seitentyp (Einzel/Doppelseite) werden jetzt auch im Fenster “Use Other PDF Menu” angezeigt
    • Im “Use Other PDF” Fenster wird gewarnt, wenn sich Seitengröße oder Seitentyp von den Parametern des aktuellen Buchs (in das die PDF-Seiten je eingebunden werden sollen) unterscheiden
  • Das “New” Fenster ist neu gestaltet. 4 Optionen stehen zur Verfügung: Neues Buch aus (Seiten-) Bildern, ein Fotobuch aus einer Bildauswahl, ein leeres Buch oder in Buch aus einer PDF Datei.

    Drag&Drop wird unterstützt. Nach dem “Drop” startet die Erzeugung des Buchs automatisch. Im Fall einer PDF-Konvertierung allerdings aus Zeitgründen nur die ersten 10 Seiten.
    Zieht man Bilder oder eine PDF-Datei auf der ersten Seite des “New”-Fensters auf das entsprechende Icon, wird ein in den meisten Fällen “passendes” Buch vollkommen automatisch erstellt; ohne einen weiteren Klick!
    Nach einem Klick auf eines der Icons öffnet sich das nächste Fenster, in dem zusätzliche Einstell-Optionen zur Verfügung stehen. Nach der Prüfung oder Anpassung können wieder die entsprechenden Dateien in das EIngabefeld oder den “Open Browser” Button gezogen und abgelegt werden. Das neue Buch wird dann wieder weitgehend automatisch mit diesen Parametern erstellt.
    Je nach Kenntnisstnd und Anforderung kann man so schnell die passende und am besten geeignete Methode finden.

Dann bekommt man schnell ein Gefühl für die Logik und die möglichen Optionen. Die Dokumentation wird nach dem nächsten Update zusätzliche Hilfestellung geben

  • Open Automatically nun als Option
  • Redesign Basic Settings und Javascript Settings Fenster
  • Neues Fenster zum Design der Navigation Bar / Burger Menüs
  • Unterstützung von GIF Bildern/Animationen 20190824
    Zusätzlich zu JPG und PNG Bildern können nun auch GIF Bilder/Animationen wie normale Bild-Elemente auf Seiten gesetzt werden.
    Damit sind kleine Animationen auf Seiten im Buch möglich
  • Das Custom Logo ist nun “repsonsive” im Browser: Die Größe ,wird als Prozentwert der definierten Seitenhöhe festgelegt und passt sich damit der Buchgröße an.
  • Fehler-Beseitigung und einige kleinere Verbesserungen.
    Beispiel:
    • Burger Menu, Navbar: wurde nicht immer (korrekt) angezeigt; vor allem bei vielen Icons
    • New Project (empty Pages)
      Die Seitenmaße (page width und page height) werden jetzt erst überprüft, wenn man die Eingabe mit “Enter” abschließt oder die Maus das Eingabefeld verlässt.
      Vor dieser Änderung war es nicht mehr möglich, einen neuen Wert einzugeben, sobald der alte Wert gelöscht wurde (die Größe wurde sofort als “zu klein” bemängelt).
      Außerdem kann jetzt der Sprachcode in der üblichen Syntax (wie beim PDF-Namen: exakt 2 Kleinbuchstaben am Ende des Namens nach einem Unterstrich) an den Namen angehängt.
      Er wird dann übernommen und angezeigt und beim Abschließen mit Continue vom Projektnamen entfernt.
      Dies sichert nicht nur gegen eine unbeabsichtigte Eingabe ab, sondern kann auch für eine schnelle Definition des Sprachcodes genutzt werden.
    • Die Menü-Key-Codes (short code wie “STRG-v”, die sowieso niemand nutzte) störten z.B. beim Kopieren eines Lizenzschlüssels! Anstatt den Schlüssel aus dem Clipboard mit STRG-v einzufügen, öffnete sich das mz3Viewer Settings Fenster.
      Die Kurzbefehle wurden entfernt.
    • navbar und burger menu Logik
      Bei vielen Icons klappte die Aufteilung nicht wie gewünscht.
      Jetzt wird bis zu einer Höhe von 12px versucht, die Icons zu saklieren, damit sie in eine Navbar-Zeile passen. Darunter wird auf das Burger Menu umgeschaltet.
    • Falsches Seitenverhältnis bei einigen Videos
      Falls ein Video keine “quadratischen” Pixel nutzt (z.B. wg einer Anpassung PAL -> HD), wurde in den Datei-Metadaten der falsche Wert angezeigt und auch vom Programm ausgelesen und verwertet.
      Dies führte zu verzerrten Vorschaubildern.
      Nun wird das “echte” Seitenverhältnis des (laufenden) Videos ausgelesen und genutzt. Damit können korrekte Vorschaubilder auch aus solchen Videos erstellt werden.
    • 2 parallel ausgeführte Programmteile “kämpften” um die Statusanzeige
      Die konnte z.B. beim Hinzufügen von Seitenbildern (Page Images PIMGs) passieren, da sowohl Bilder kopiert als auch auf Seiten gesetzt werden müssen.
      Dies wird jetzt unterbunden. Gleichzeitig wurde die Statusanzeige vereinfacht: Es wird nicht mehr der Name der gerade kopierten Datei angezeigt (was sowieso nur schwer zu erkennen war und bei langen Namen zu weiteren Unschönen Effekten führte), sondern meist nur die Anzahl der noch zu kopierenden Dateien. Was genügend Informationen gibt und einfacher zu lesen ist.
      Beispiele solcher Anzeigen:
  • Redesign Basic Settings and Javascript Settings Windows
    Those two windows should be easier to use now: better strucutured, less buttons and options (without restricting functionality)

FLASH Unterstützung eingestellt

Da inzwischen alle Browser es dem “normalen” Nutzer fast unmöglich machen, FLASH-Programme noch zu nutzen, haben wir uns entschlossen, nach über 10 Jahren vollem FLASH-Support diesen Trend zu akzeptieren und mz3Tool entsprechend aufzuräumen.

File – Open Recent Project Feature

Dieses Kommando wurde entfernt. Die mit diesem Kommando angebotenen Funktionen können nun alle über das ‘Open Project’ Menü ausgeführt werden.

File – Open Project

Dieses Kommando ist nun das zentrale Kommando zum Verwalten und Starten/Öffnen vin Mz3 Projekten (“Mz3 Büchern”).
Es wird jetzt die Information der Original-Projektdaten genutzt (mz3ToolBookData.xml und ggf mz3-Datei aus den Projekt-Ordnern).
Die frühere mz3ToolPathsData XML Datei in dem Benutzer-spezifischen Ordner C:\Users\(userName)\AppData\Roaming\de.megazine3.air.mz3Tool\Local Store\settingsData Ordne (bei einem Windows10 System) wird nicht mehr benötigt.
Die zusätzliche Spalte “Modification Date” zeigt das Datum der letzten Änderung an. Nach dieser Spalte wird zu Beginn sortiert und man erhält die zuletzt bearbeiteten Projekte in der korrekten zeitlichen Reihenfolge. Das aktuell bearbeitete Projekt findet man in der ersten Zeile. Es ist bereits ausgewählt und wird per Doppelklick oder “OPEN” Knopf sofort wieder geöffnet.

Außerdem handelt es sich nun um ein “echtes” natives Fenster und nicht mehr um ein Pop-Up-Fenster und lässt sich daher frei positionieren und skalieren!
Es werden viele zusätzlich Informationen angezeigt, die einen guten Überblick über alle Mz3 Projekte verschaffen und Fehler/Ungereimtheiten aufdecken.
Die Tabelle zeigt nun Projekt-Details übersichtlich zusammengefasst an:

  • Änderungsdatum
  • Erstelldatum (bzw. Datum der letzten Änderung der zugrunde liegenden PDF Datei)
  • Seitenanzahl
  • Anhzahl der verfügbaren Thumbnails
  • Anzahl aller im Mz3 Projekt genutzten Elemente wie Bilder, Videos, Audio-Dateien, Links

Die Anzahl verwendeter Elemente (Bild-, Audio und Video-Dateien sowie der Thumbnails und “Seitenbilder) wird jetzt getrennt nach Sprache angezeigt.
Es kann nach allen Spalten sortiert werden. Damit sind Antworten auf die folgenden typischen Fragen schnell und komfortabel zu finden:

  • Wurden (alle) Thumbnails erzeugt?
  • Wurden alle Seiten konvertiert?
  • In welchen Büchern werden Videos genutzt?
  • Welche Sprachen werden unterstützt?
  • Welche Mz3 Titel sind mehrsprachig?
  • sind die genutzten Daten für alle Sprachen gleich
  • Welche PDF Datei wurde als Basis für die Seiten genutzt?
  • Welche Seitengrößen haben die Mz3 Titel?
  • Welches sind “Doppelseiten-Bücher”??

Sollten einige Zellen noch keine Daten enthalten (oder ein oder mehrere “?”), dann wurde das entsprechende Mz3 Projekt sehr wahrscheinlich mit einer früheren Version von mz3Tool erstellt. In diesem Fall kann eventuell ein “Commands – Update” die Konfigurationsdaten automatisch erneuern.

Neu hinzugekommen ist auch eine “Status”-Spalte mit einer Zusammenfassung des Projekt-Status:.

  • invalid
    Es wurde keine mz3oolBookData.xml Konfigurationsdatei und keine mz3 Projektdatei gefunden
  • (leer)
    Der Normalfall bei einsprachigen Büchern: Alles OK.
  • n mz3 xx
    Der Normalfall bei Vorhandensein mehrerer Sprachen: Alles OK
    “n” steht für die Anzahl gefundener mz3 Projektdateien und xx ist eine Kennung zur Auswahl-Strategie des mz3 Projekts.
    Folgende Kenungen sind möglich:
    • ML
      Die “multilingual” Datei wurde ausgewählt und es wird ein mehrsprachiges Buch angezeigt
    • SZ
      Es wurde die größte mz3-Datei gewählt (“SZ” steht für “size”)
    • LL
      Es wurde die mz3 Datei gewählt, welche der lokalen Sprache entspricht (“LL” steht für “local language”).
    • New
      Es wurde die neueste (also zuletzt bearbeitete) Projektdatei ausgewählt

Nur wenn gezielt ein einsprachiges Buch in einer der zusätzlich hinzugefügten Sprachen erstellt wird, gibt es auch die entsprechende mz3-Datei dieser Sprache und die angezeigte Anzahl “n” der mz3 Dateien wird größer als 2.
Ein einsprachiges Buch kann auch bei mehreren vorbereiteten Sprachen leicht erstellt werden, indem die anderen Sprachen (vorübergehend) versteckt werden (“hide language”).

File – Delete Project

Die Tabelle enthält nun dieselben Inforamtionen wie die ‘Open Project’ Tabelle, was eine Kontrolle ermöglicht, bevor das Projekt gelöscht wird.
Ein gelöschtes Projekt kann nicht wieder hergestellt werden!!
Sinnvollerweise sollte vorher oder zumindest regelmäßig ein Backup aller Projektdaten erfolgen!

Commands – Publish/Distribute

Die Programmlogik zur Erstellung der Online und Offline Packages wurde überarbeitet und Fehler beseitigt. Die Benutzerführung wurde verbessert (bessere Rückmeldungen).

Mehr Komfort bei der Positionierung von AREA Elementen

Größe und Position eines AREA (klickbarer Bereich) Elements können jetzt schnell auch auf eine gesamte Seiten und Seitenhälfte (im Fall eines Doppelseitenbuchs) aufgezogen werden.
Dies hilft z.B. bei ganzseiteigen Anzeigen in einem Magazin,, die zum Hersteller verlinkt werden sollen.
Dazu steht im Haupteingabefenster ein Knopf zur Verfügung, der zwischen 4 Varianten umschaltet. Es muss nicht mehr manuell angepasst oder ins “Advanced Edit” Fenster umgeshcaltet werden:

  • ‘custom’ (manuell eingestellte) Größe und Position
    Ein manuelles Ändern der Größe oder Position eines AREA Elements schaltet wieder auf diese Variante zurück.
  • full page (komplette Seite, bei einer Doppelseite über die volle Breite eines aufgeschlagenen Buchs.
  • left half (linke Hälfte / Seite eines aufgeschlagenen Buchs)
  • right half (rechte Hälfte / Seite eines aufgeschlagenen Buchs)

Verbessertes Verwalten mehrsprachiger Bücher

Sprachen können jetzt direkt durch Eingabe des Sprachkürzels vorbereite/definiert werden. Neue Sprachen sind nicht gleich aktiv, d.h. nicht sofort im Buch auswählbar. Sie müssen erst per Klick zur Benutzung freigegeben werden.
    

Genau so schnell können Sprachen wieder versteckt werden und kann eine (aktive) Sprache als Default-Sprache definiert werden.

Eine große Hilfe ist die vollständige Unerstützung des Löschens einer Sprache: Es werden alle Verweise und sprach-spezifischen Dateien gelöscht!
Früher musste man dies im “Manage Elements Window” mit relativ hohem Aufwand und Risiko manuell durchführen.

Verbesserte Unterstützung beim Hinzufügen von Seitenbildern

Hat man Bilder ausgewählt, die auf Seiten gesetzt werden sollen, wird der Dateiname nun recht intensiv analysiert und die beste Strategie, die Bilder auf die gewünschten Seiten zu setzen, vorgeschlagen.
Man muss in den meisten Fällen nicht mehr selber entscheiden, ob die Seitennummer aus einer Nummer im Dateinamen genutzt wird oder besser die Bilder in der (alphabetischen) Reihenfolge der Dateinamen hinzugefügt werden.
Nur in Ausnahmefällen muss man eingreifen und kann dann eine Kombination der vielfältigen Einstelloptionen nutzen, um zum gewünschten Ergebnis zu kommen.
Die Anzeige wurde aufgeräumt und übersichtlicher. Unnötige Bedienelemente sind entfallen.

Unterstützung von Page Parametern (seitenspezifische Parameter) bei der JavaScript Version

Jetzt werden auch in der JavaScript Variante unterstützt.
Es werden nur die Seiten-Parameter angezeigt, diein der JavaScript Version ausgewertet werden. Die Nummer der JavaScript Seiten-Parameter (5) ist noch kleiner als die Anzahl der mz3Viewer Seiten-Parameter (24).
Auch die Anzahl Book Parameter (Buch-spezifische Parameter) istin der JavaScript Variante niedriger: Aktuell 16 für JavaScript und 49 für mz3Viewer.

Open Automatically nun als Option

Mit einem Klick ins Buch wird nicht mehr automatisch das “Modify Elements on Pages” Fenster aufgerufen. Dies ermöglicht eine “gewohnte” Bedienung des Buchs, d.h. Links funktionieren undman kann auch ein Video im Buch starten.
Das Fenster zum Verwalten und Analysieren der auf den Seiten platzierten Elemente (Bilder, Videos, Sound und Links) kann wie bereits vorher über den Menüpunkt “File – Modify Elements on Pages” geöffnet werden.
Wer das alte Verhalten gewohnt ist nd vorzieht, kann dies über die Basic Settings wieder einstellen:

h3.Redesign Basic Settings und Javascript Settings Fenster

Beide Fenster wurden umstrukturiert und sollten nun übsichtlicher ein einfacher zu bedienen sein. Es muss auch weniger geklickt werden (ein Schließen des Fensters speichert automatisch).

Neues Übersichtsfenster vor einem Publish

Ein neues kleines Fenster gibt eine Kurzübersicht zum Projekt-Status. Fehler werden rot, wichtige Parameter blau hervorgehoben. Auf diese Art lassen sich Probleme wie nicht beötigte Dateien, die das Paket nur unnötig groß machen, vermeiden.
Anzeige mit “Problemen”:

Anzeige nach Beseitigung der Probleme (Löschen nicht mehr benötigter Dateien)

Neues Fenster zum Design der Navigation Bar / Burger Menüs

Das Definieren von Links mit zugehörigen Symbolen und das Konfigurieren der Sprachumschalter wurde ebenfalls komplett überarbeitet und erfolgt jetzt gemeinsam in einem Fenster.
Außerdem die Eingabe und das Anpassen nun wesentlich einfacher und komfortabler:

Revision: 76
Last modified: 2019/10/10

Reaktion

War das hilfreich?

Ja Nein
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Hinterlasse einen Kommentar.

Kommentar senden